您的位置:首页 > 其它

DNA Sorting(stable_sort)

2018-01-19 11:43 267 查看
时间限制:1000 ms  |  内存限制:65535 KB 难度:2 描述 One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 输入The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.输出Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCATSample OutputCCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAASource题意:给出下面字符串的长度n,字符串的个数m,要求按逆序数从小到大输出这m个串。如果两个串的逆序数相同,就按照原来的顺序输出来。
本来觉得数据挺小,挺简单的,提交上去一直错,原来是sort的问题,sort和stable_sort其中的区别是,带有stable的函数可保证相等元素的原本相对次序在排序后保持不变。既然相等,还管他相对位置呢,也分不清 楚谁是谁了?这里需要弄清楚一个问题,这里的相等,是指你提供的函数表示两个元素相等,并不一定是一摸一样的元素.。比如BAC, CAC的逆序数都是1,原来BAC在CAC前面,排完序后可能CAC跑到BAC前面。所以这道题一直错,把sort改成stable_sort就ok了,好海森~~
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
string ss;
int num;
}p[110];
int cmp(node p1,node p2)
{
return p1.num<p2.num;
}
int f(string s)
{
int sum=0;
for(int i=0;i<s.size()-1;i++)
{
for(int j=i+1;j<s.size();j++)
{
if(s[i]>s[j])
sum++;
}
}
return sum;
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<m;i++)
{
cin>>p[i].ss;
p[i].num=f(p[i].ss);
}
stable_sort(p,p+m,cmp);!!!
for(int i=0;i<m;i++)
cout<<p[i].ss<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: