您的位置:首页 > 其它

POJ2060-Taxi Cab Scheme (最小路径覆盖)

2018-01-18 19:14 465 查看
Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The
4000
booked rides in each scenario are sorted in order of increasing departure time.

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input

2

2

08:00 10 11 9 16

08:07 9 16 10 11

2

08:00 10 11 9 16

08:06 9 16 10 11

Sample Output

1

2

题目:POJ2060

题意:给你一些出租车预定消息,包括开始时间,起点坐标以及终点坐标,如果一辆出租车在处理完当前预定后,能够提前1分钟以上到达下一个预定订单的起点,那么出租车可以接着进行下个订单,问处理完所有订单最少需要多少出租车。

思路:要求最少的出租车数目,那么每辆被派出的出租车要尽可能完成多的订单。

那么不妨假设,开始时我们对于每个订单都派出一辆出租车,我们就需要n辆出租,但是为了节约,如果我们让一辆出租车在完成了一个订单以后,继续去找下一个可以执行的订单,这样,我们每匹配到一个订单,出租车的数量就会减1

题目就被我们转化成了一个二分匹配问题,我们只需要对每个订单标号,存在匹配关系的订单进行建边,然后二分匹配,答案就是:订单数-最大匹配数

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const int maxn=505;
int vis[2*maxn],match[2*maxn],p[maxn],num,n,m;
struct plan
{
int t,sx,sy,ex,ey;
friend bool operator< (plan a,plan b)
{
return a.t<b.t;
}
}pl[maxn];
struct edge
{
int st,en,next;
}e[maxn*maxn];
void init()
{
met(p,-1);
num=0;
}
void add(int st,int en)
{
e[num].st=st;
e[num].en=en;
e[num].next=p[st];
p[st]=num++;
}
int matched(int u)
{
for(int i=p[u]; i!=-1; i=e[i].next)
{
int v=e[i].en;
if(!vis[v])
{
vis[v]=1;
if(!match[v]||matched(match[v]))
{
match[v]=u;
match[u]=v;
return 1;
}
}
}
return 0;
}
int hungarian()//匈牙利算法求最大匹配
{
int ans=0;
met(match,0);
for(int i=1; i<=m; i++)
{
if(!match[i])
{
met(vis,0);
if(matched(i))
{
ans++;
}
}
}
return ans;
}
int main()
{
scan(n);
while(n--)
{
init();
scan(m);
for(int i=1;i<=m;i++)
{
int a,b;
scanf("%d:%d%d%d%d%d",&a,&b,&pl[i].sx,&pl[i].sy,&pl[i].ex,&pl[i].ey);
pl[i].t=a*60+b;
}
sort(pl+1,pl+1+m);//对订单按时间排序,时间晚的肯定无法和时间早的进行匹配
for(int i=1;i<=m;i++)
{
for(int j=1;j<i;j++)
{
if(pl[i].t-1-(abs(pl[j].ex-pl[j].sx)+abs(pl[j].ey-pl[j].sy)+(abs(pl[i].sx-pl[j].ex)+abs(pl[i].sy-pl[j].ey)))>=pl[j].t)add(i,j+maxn);//满足条件的订单建边,注意虚拟点
}
}
prin(m-hungarian());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: