您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence(KMP入门)

2018-01-17 21:31 591 查看
A - Number Sequence
HDU - 1711

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
鹏哥口中短小精悍的KMP来了,寻找子字符串的最快算法,KMP精髓在于寻找next数组,这道题就是简单的两个函数调用就行#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
int a[1000005], b[1000005];
int ne[1000005];
int aa, bb;
void getnext()//得到next数组
{
int i = 0, j = -1;
ne[0] = -1;
while(i < bb)
{
if(j == -1||b[i] == b[j])
ne[++i] = ++j;
else j = ne[j];
}
}
int kmpcompare()//判断是否存在位置符合条件
{
// int len1 = strlen(a);
// int len2 = strlen(b);
getnext();
int i = 0, j = 0;
while(i < aa && j < bb)
{
if(j == -1|| a[i] == b[j]){j ++; i ++;}
else j = ne[j];
}
if(j == bb)return i - j + 1;
else return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&aa,&bb);
for(int i = 0; i < aa; i ++)
scanf("%d",&a[i]);
for(int i = 0; i < bb; i ++)
scanf("%d",&b[i]);
printf("%d\n",kmpcompare());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: