您的位置:首页 > 其它

【DFS】POJ 2386 Lake Counting

2018-01-17 18:27 441 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39188 Accepted: 19426
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.


Sample Output
3


Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

USACO 2004 November

题意不难理解,让你找水坑的数量,W连在一起的一块图形算作一个水坑。

典型的dfs的题目,注意每次走过的水坑都要把他标记防止重复走,我这里是直接把走过的水坑标记成‘.’。对每个水坑dfs标记完所有的水,最后统计dfs的次数就是水坑的数量。

上AC代码

#include<stdio.h>

#define MAX_NUM 106

char Map[MAX_NUM][MAX_NUM];
int n,m,ans;
int f[8][2] = {{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};//八个方向。

void dfs(int x,int y)
{
Map[x][y] = '.';//把现在走过的位置替换为 . 。
for(int i = 0 ; i < 8 ; i++)
{
int tx = x + f[i][0];
int ty = y + f[i][1];
if(tx >= 0 && ty >= 0 &&tx <n&&ty <m&&Map[tx][ty]!='.')//判断是否越界。
{
dfs(tx,ty);

}
}
return ;
}

void solve(void)
{
while(~scanf("%d%d",&n,&m))
{
ans = 0;
for(int i = 0 ; i < n ; i++) scanf("%s",Map[i]);
for(int i = 0 ; i < n ; i++)
for(int j=  0 ; j < m ; j++)
if(Map[i][j]=='W')
{
ans++;
dfs(i,j);
Map[i][j] = '.';
}
printf("%d\n",ans);
}
}

int main(void)
{
solve();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: