您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集)

2018-01-16 20:04 387 查看
水一发,这才是一个入门题应有的样子 (ಥ_ಥ)  ,前一道看了半天,还是我太菜了ORZ,现在大概明白并查集是个啥回事了,代码和模板还是差不多,不过少了点东西,如有错误欢迎指正。

题目:

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

思路:

各自为爹—>寻亲—>认亲(ಥ_ಥ)  

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<queue>
using namespace std;
#define eps 1e-8
#define mod 1000000007
#define ll long long
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))

int f[1005];
//寻亲
int getf(int a){
if(f[a]==a)return a;
f[a]=getf(f[a]);
return f[a];
}

int main(){
int i,n,m,T,a,b;
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)f[i]=i;//初始化
while(m--){
scanf("%d%d",&a,&b);
f[getf(b)]=getf(a); //认亲
}
int ans=0;
for(i=1;i<=n;i++)if(f[i]==i)ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: