您的位置:首页 > 其它

UVA11462 Age Sort【基数排序/桶排序/计数排序】

2018-01-13 18:50 465 查看
              
You are given the ages (in years) of all people of a country with at least 1 year of age. You know thatno individual in that country lives for 100 or more years. Now, you are given a very simple task ofsorting all the ages in ascending order.

Input

There are multiple test cases in the input file. Each case starts with an integer n (0 < n ≤ 2000000), thetotal number of people. In the next line, there are n integers indicating the ages. Input is terminatedwith a case where n = 0. This case should not
be processed.

Output

For each case, print a line with n space separated integers. These integers are the ages of that countrysorted in ascending order.

Warning: Input Data is pretty big (∼ 25 MB) so use faster IO.

Sample Input

5

3 4 2 1 5

5

2 3 2 3 1

0

Sample Output

1 2 3 4 5

1 2 2 3 3

问题链接UVA11462 Age Sort

问题简述:(略)

问题分析

  数据的数量虽然多,值的范围比较小,准备一些桶把这些数据放进去就好了。

程序说明
  需要注意输出格式的控制。

题记

  桶排序是一种非常奇妙的排序方法。

#include <stdio.h>
#include <string.h>
#define N 100
int main()
{
int a
,flag=0,i,j;
int n;
while(scanf("%d",&n)!=EOF&&n!=0)
{
flag=0;
memset(a,0,sizeof(a));
while(n--)
{
scanf("%d",&i);
a[i]++;
}
for(i=1;i<N;i++)
for(j=1;j<=a[i];j++)
{
if(flag)
putchar(' ');
printf("%d",i);
flag=1;
}
putchar('\n');
}
return 0;
}
/* UVA11462 Age Sort */

#include <stdio.h>
#include <string.h>

#define N 100

int count
;

int main(void)
{
int n, a, flag, i, j;

while(~scanf("%d", &n) && n) {
memset(count, 0, sizeof(count));

while(n--) {
scanf("%d", &a);

count[a]++;
}

/* 输出结果 */
flag = 0;
for(i=1; i<N; i++) {
for(j=1; j<=count[i]; j++) {
if(flag)
putchar(' ');
printf("%d", i);
flag = 1;
}
}
putchar('\n');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: