您的位置:首页 > 编程语言 > Java开发

PAT-Java-1005-Spell It Right (20)

2018-01-13 16:23 555 查看

1005. Spell It Right (20)

题目阐述

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

原题链接

题目分析

~~~(略)

代码如下

import java.util.Scanner;

public class Main {

public static void main(String[] args) {
String[] word = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
Scanner s = new Scanner(System.in);
String str = s.nextLine().trim();
s.close();
int num = 0;
for(int i=0; i<str.length(); i++) {
num += str.charAt(i) - '0';
}
str = String.valueOf(num);
for(int i=0; i<str.length(); i++) {
if(i == 0) System.out.print(word[str.charAt(i) - '0']);
else System.out.print(" " + word[str.charAt(i) - '0']);
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: