您的位置:首页 > 其它

UVA 10763 Foreign Exchange

2018-01-12 10:48 148 查看
Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last
few years, demand has sky-rocketed and now you need assistance with your task.

The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student
wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

Input
The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange information
for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative integer
numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should
not be processed.

Output
For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

Sample Input

10

1 2

2 1

3 4

4 3

100 200

200 100

57 2

2 57

1 2

2 1

10

1 2

3 4

5 6

7 8

9 10

11 12

13 14

15 16

17 18

19 20

0

Sample Output

YES

NO

题意:有n(1<=n<=500000)个学生想交换到其他学校学习。为了简单起见,规定每个想从A学校换到B学校的学生必须找一个想从B换到A的学生,如果每个人都找到了,就输出YES,否则就输出NO。

很简单的,直接用map<pair<int, int>, int> 计数,将(A,B)存到pair里面,如果A < B 就+1,如果A > B 就-1即可

#include <map>
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
pair<int, int> pr;
map <pair<int, int>, int> mat;
int main() {
int n;
int A, B;
while(~scanf("%d",&n) && n) {
mat.clear();
for(int i = 0; i < n; i++) {
scanf("%d%d", &A, &B);
if(A < B) {
mat[make_pair(A, B)]++;
}
else if(A > B){
mat[make_pair(B, A)]--;
}
}
bool flag = false;
map<pair<int, int>, int>::iterator it;
for(it = mat.begin(); it != mat.end(); it++) {
if(it->second) {
flag = true;
break;
}
}
if(flag) printf("NO\n");
else printf("YES\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: