您的位置:首页 > 其它

POJ3281 Dining(最大流+拆点)

2018-01-11 21:00 330 查看
Dining

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20182 Accepted: 8970
Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink
a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D 

Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers
denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3


Sample Output
3


Hint

One way to satisfy three cows is: 

Cow 1: no meal 

Cow 2: Food #2, Drink #2 

Cow 3: Food #1, Drink #1 

Cow 4: Food #3, Drink #3 

The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

题意:有n个奶牛,f种食物,d种饮料,每种饮料和食物只有一个,每个奶牛有喜欢的食物和饮料,当一头奶牛同时获得喜欢的食物和饮料时,这个奶牛就满足了,问最多让多少只奶牛满足

网络流问题,为解决一头牛与多个饮料和食物匹配,需要拆点,将牛拆为牛左和牛右,建边为1,然后超级源点与每个食物建边为1,食物与每头牛左建边为1,牛右与饮料建边为1,饮料与汇点建边



图大致就是这样

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=1000+50;
const int maxm=1e6+50;
struct node
{
node() {};
node(int tv,int tw,int tnext)
{
v=tv,w=tw,next=tnext;
};
int v,w,next;
} e[maxm];
int first[maxn],vis[maxn],dis[maxn],tot;
void add_edge(int u,int v,int w)
{
e[tot]=node(v,w,first[u]);
first[u]=tot++;
e[tot]=node(u,0,first[v]);
first[v]=tot++;
}
int bfs(int s,int t)
{
mem(vis,0);
mem(dis,0);
queue<int>q;
q.push(s);
vis[s]=1;
while(!q.empty())
{
int u=q.front();
q.pop();
for(int i=first[u]; ~i; i=e[i].next)
{
if(!vis[e[i].v]&&e[i].w>0)
{
vis[e[i].v]=1;
dis[e[i].v]=dis[u]+1;
q.push(e[i].v);
}
}
}
return dis[t];
}
int dfs(int u,int t,int flow)
{
if(u==t)return flow;
for(int i=first[u]; ~i; i=e[i].next)
{
if(dis[e[i].v]==dis[u]+1&&e[i].w>0)
{
int dd=dfs(e[i].v,t,min(e[i].w,flow));
if(dd)
{
e[i].w-=dd;
e[i^1].w+=dd;
return dd;
}
}
}
dis[u]=0;
return 0;
}
int Dinic(int s,int t)
{
int ans=0,flow;
while(bfs(s,t))
{
while(flow=dfs(s,t,INF))
ans+=flow;
}
return ans;
}
void init()
{
mem(first,-1);
tot=0;
}
int main()
{
int i,j,F,D,x,f,d,n;
scanf("%d%d%d",&n,&f,&d);
init();
for(int i=1; i<=f; i++)
add_edge(0,i,1);
for(int i=1; i<=d; i++)
add_edge(f+2*n+i,2*n+f+d+1,1);//饮-》汇
for(i=1; i<=n; i++)
{
scanf("%d%d",&F,&D);
add_edge(i+f,i+f+n,1);
for(j=1; j<=F; j++)
{
scanf("%d",&x);
add_edge(x,i+f,1);//食物-》牛左
}
for(j=1; j<=D; j++)
{
scanf("%d",&x);
add_edge(i+f+n,f+2*n+x,1);//牛右-》饮
}
}
printf("%d\n",Dinic(0,2*n+f+d+1));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: