您的位置:首页 > 其它

1020. Tree Traversals (25)

2018-01-11 15:34 375 查看


1020. Tree Traversals (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:
4 1 6 3 5 7 2


#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;
int post[35];
int in[35];
typedef struct Node *node;
struct Node{
int x;
node left;
node right;
};
node build(int s1,int e1,int s2,int e2){
node T=(node)malloc(sizeof(struct Node));
T->left=T->right=NULL;
T->x=post[e1];
int i,root;
for(i=s2;i<=e2;i++){
if(post[e1]==in[i]){
root=i;break;
}
}
if(root!=s2){
T->left=build(s1,root-s2+s1-1,s2,root-1);
}
if(root!=e2){
T->right=build(root-s2+s1,e1-1,root+1,e2);
}
return T;
}
int main(){
int n,i;
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d",&post[i]);
}
for(i=0;i<n;i++){
scanf("%d",&in[i]);
}
node T=build(0,n-1,0,n-1);
queue<node>q;
q.push(T);
int flag=1;
while(!q.empty()){
node head=q.front();
q.pop();
if(flag){
printf("%d",head->x);flag=0;
}
else{
printf(" %d",head->x);
}
if(head->left){
q.push(head->left);
}
if(head->right){
q.push(head->right);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: