您的位置:首页 > 编程语言 > Java开发

PAT-Java-1001-A+B Format (20)

2018-01-10 14:12 393 查看

1001. A+B Format (20)

题目阐述

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

原题链接

题目分析

这道题没什么值得分析的,无非就是格式化输出罢了,如果直接调用printf的合适的参数就可以一次得到正确的结果。

代码如下

import java.util.Scanner;
public class Main {
public static void main(String[] args){
Scanner sc=new Scanner(System.in);
int a = sc.nextInt();
int b = sc.nextInt();
System.out.printf("%,d", a+b);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: