您的位置:首页 > 其它

AtCoder Beginner Contest 085 C - Otoshidama【暴力】

2018-01-08 10:34 567 查看

C - Otoshidama

Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

The commonly used bills in Japan are 10000-yen, 5000-yen and 1000-yen bills. Below, the word “bill” refers to only these.

According to Aohashi, he received an otoshidama (New Year money gift) envelope from his grandfather that contained N bills for a total of Y yen, but he may be lying. Determine whether such a situation is possible, and if it is, find a possible set of bills contained in the envelope. Assume that his grandfather is rich enough, and the envelope was large enough.

Constraints

1≤N≤2000

1000≤Y≤2×107

N is an integer.

Y is a multiple of 1000.

Input

Input is given from Standard Input in the following format:

N Y

Output

If the total value of N bills cannot be Y yen, print -1 -1 -1.

If the total value of N bills can be Y yen, let one such set of bills be “x 10000-yen bills, y 5000-yen bills and z 1000-yen bills”, and print x, y, z with spaces in between. If there are multiple possibilities, any of them may be printed.

Sample Input 1

9 45000

Sample Output 1

4 0 5

If the envelope contained 4 10000-yen bills and 5 1000-yen bills, he had 9 bills and 45000 yen in total. It is also possible that the envelope contained 9 5000-yen bills, so the output 0 9 0 is also correct.

Sample Input 2

20 196000

Sample Output 2

-1 -1 -1

When the envelope contained 20 bills in total, the total value would be 200000 yen if all the bills were 10000-yen bills, and would be at most 195000 yen otherwise, so it would never be 196000 yen.

Sample Input 3

1000 1234000

Sample Output 3

14 27 959

There are also many other possibilities.

Sample Input 4

2000 20000000

Sample Output 4

2000 0 0

题意: 首先有1000,5000,10000面值的某国钞票,给你张数和总面值,问你能否有一种组合(x,y,z)恰好使得(x*10000 + y*5000 + x*1000 == Y && x + y + z == N)

分析: 看到范围才2e7,直接暴力即可

参考代码

#include<bits/stdc++.h>

using namespace std;

int main(){
ios_base::sync_with_stdio(0);
int n,s;cin>>n>>s;
if(s % 1000 != 0) {
printf("-1 -1 -1\n");
} else {
s /= 1000;
bool flg = false;
for(int i = 0;i <= 20000;i++) {
for(int j = 0;j <= 10000;j++) {
if(i + j*5 > s) {
continue;
}
if( ((s - (i + j*5)) % 10 == 0 ) ) {
if(i + j + ((s - (i + j*5))/10) == n) {
printf("%d %d %d\n",((s - (i + j*5))/10),j,i);
return 0;
}
}
}
}
printf("-1 -1 -1\n");
}

return 0;
}


如有错误或遗漏,请私聊下UP,ths
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐