您的位置:首页 > 其它

POJ3006 Dirichlet's Theorem on Arithmetic Progressions【筛选法】

2018-01-05 07:28 381 查看
Dirichlet's Theorem on Arithmetic Progressions

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19673 Accepted: 9836
Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., a, a + d, a +
2d, a + 3d, a + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured
by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers a, d, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, d, and n separated by a space. a and d are
relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset a, d, n should be the nth prime number among those contained in the arithmetic sequence beginning with a and
increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input
367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output
92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

Source
Japan 2006 Domestic

问题链接POJ3006 Dirichlet's Theorem on Arithmetic Progressions

问题简述

  狄利克雷定理:给定初始a与公差d,若a与d互素,则a,a+d,a+2d,a+3d,,,可以产生无限个素数。现在给定三个正数a,d,n,要求这个数列的第n个素数是多少?且知道所求的数小于1000000(一百万)。

问题分析

  需要计算的数有多组,预先使用筛选法求出素数是必要的(打表)。

  然后,查找计算一下就可以了。

程序说明

  都是套路,不解释。

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* POJ3006 Dirichlet's Theorem on Arithmetic Progressions */

#include <iostream>
#include <math.h>
#include <string.h>
#include <stdio.h>

using namespace std;

const int N = 1e6;
const int SQRTN = ceil(sqrt((double) N));
bool isPrime[N + 1];

// Eratosthenes筛选法
void esieve(void)
{
memset(isPrime, true, sizeof(isPrime));

isPrime[0] = isPrime[1] = false;
for(int i=2; i<=SQRTN; i++) {
if(isPrime[i]) {
for(int j=i*i; j<=N; j+=i)  //筛选
isPrime[j] = false;
}
}
}

int main()
{
esieve();

int a, d, n;
while(~scanf("%d%d%d", &a, &d, &n) && a && d && n) {
int cnt = 0;
for(;;) {
if(isPrime[a])
if(++cnt == n) {
printf("%d\n", a);
break;
}
a += d;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: