您的位置:首页 > 产品设计 > UI/UE

POJ 3061 Subsequence(尺取法)

2018-01-03 17:20 369 查看
Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17457 Accepted: 7433
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3


尺取法

先从第一个数开始加,大于s之后,减去该区间的左区间。一直减

知道小于s 。然后在加右区间的数

每次更新求最短的长度

和下面这题很类似

5Nod 1127 最短的包含字符串 (尺取法)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
using namespace std;
int main(){
int t;
scanf("%d",&t);
while(t--){
int n,s;
scanf("%d%d",&n,&s);
int a[100001];
for(int i=0;i<n;i++) scanf("%d",&a[i]);
int sum=0,zuo=0;
int cnt=1<<29;
for(int i=0;i<n;i++){
sum+=a[i];
while(sum>=s){
cnt=min(cnt,i-zuo+1);
sum-=a[zuo++];
}
}
if(cnt==1<<29){
printf("0\n");
}
else printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: