您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集入门模板题)

2018-01-03 12:31 281 查看

C - How Many Tables

HDU - 1213

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to
stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M
lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4


发现这道题之前在vjudge上做过,直接贴上来,很正宗的入门级模板

标记父节点方法有两种,大同小异

方法一

所有初始父节点标记为 -1

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int z,i,m,l;
int sum;
int pre[10000];
int find(int a)
{
if(pre[a]==-1) return a;
return pre[a] = find(pre[a]);
}
void join(int b,int c)
{
int i=find(b);
int j=find(c);
if(i!=j) pre[i]=j;
}
int main()
{
int t;
int m,n;
int a,b;
int sum;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
for(i = 1; i <= n; i ++)pre[i]=-1;

for(int i = 1; i <= m; i ++)
{
scanf("%d %d",&a,&b);
join(a,b);
}
sum=0;
for(int i = 1; i <= n; i ++)
{
if(pre[i]==-1)
sum++;
}
printf("%d\n",sum);
}
return 0;
}

方法二

所有初始父节点都设为自己本身

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int z,i,m,l;
int sum;
int pre[10000];
int find(int a)
{
if(pre[a]==a) return a;
return pre[a] = find(pre[a]);
}
void join(int b,int c)
{
int i=find(b);
int j=find(c);
if(i!=j) pre[i]=j;
}
int main()
{
int t;
int m,n;
int a,b;
int sum;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
for(i = 1; i <= n; i ++)pre[i]=i;

for(int i = 1; i <= m; i ++)
{
scanf("%d %d",&a,&b);
join(a,b);
}
sum=0;
for(int i = 1; i <= n; i ++)
{
if(pre[i]==i)
sum++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: