您的位置:首页 > 大数据 > 人工智能

AtCoder Beginner Contest 084 C - Special Trains(思路)

2017-12-31 11:04 267 查看
Problem Statement

A railroad running from west to east in Atcoder Kingdom is now complete.

There are N stations on the railroad, numbered 1 through N from west to east.

Tomorrow, the opening ceremony of the railroad will take place.

On this railroad, for each integer i such that 1≤i≤N−1, there will be trains that run from Station i to Station i+1 in Ci seconds. No other trains will be operated.

The first train from Station i to Station i+1 will depart Station i Si seconds after the ceremony begins. Thereafter, there will be a train that departs Station i every Fi seconds.

Here, it is guaranteed that Fi divides Si.

That is, for each Time t satisfying Si≤t and t%Fi=0, there will be a train that departs Station i t seconds after the ceremony begins and arrives at Station i+1 t+Ci seconds after the ceremony begins, where A%B denotes A modulo B, and there will be no other
trains.

For each i, find the earliest possible time we can reach Station N if we are at Station i when the ceremony begins, ignoring the time needed to change trains.

Constraints

1≤N≤500

1≤Ci≤100

1≤Si≤105

1≤Fi≤10

Si%Fi=0

All input values are integers.

Input

Input is given from Standard Input in the following format:

N

C1 S1 F1

:

CN−1 SN−1 FN−1

Output

Print N lines. Assuming that we are at Station i (1≤i≤N) when the ceremony begins, if the earliest possible time we can reach Station N is x seconds after the ceremony begins, the i-th line should contain x.

Sample Input 1

3

6 5 1

1 10 1

Sample Output 1

12

11

0

We will travel from Station 1 as follows:

5 seconds after the beginning: take the train to Station 2.

11 seconds: arrive at Station 2.

11 seconds: take the train to Station 3.

12 seconds: arrive at Station 3.

We will travel from Station 2 as follows:

10 seconds: take the train to Station 3.

11 seconds: arrive at Station 3.

Note that we should print 0 for Station 3.

Sample Input 2

4

12 24 6

52 16 4

99 2 2

Sample Output 2

187

167

101

0

Sample Input 3

4

12 13 1

44 17 17

66 4096 64

Sample Output 3

4162

4162

4162
0

题意:给出n个车站,并给出n个车站从第i到i+1车站所花费的时间,站台出发火车的准备时间(对于所有火车准备一次即可),站台每多少秒出发一次的时间。

思路:其实照着题目模拟即可,但是因为其他因素分心导致了这个题目没做出来,详情看代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <string>
#include <cstring>
#include <cmath>
#include <map>
#define N 505
using namespace std;
typedef long long ll;
int c[505]; //到一个车站的花费时间
int s[505]; //一个车站出发的等待时间
int f[505]; //一个车站每f秒出发一个车
int main()
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d%d%d",&c[i],&s[i],&f[i]);
for(int i=1;i<=n;i++){
int ans=0;
for(int j=i;j<n;j++){
if(ans<s[j]) //小于等待时间重新赋值
ans=s[j];
if(ans%f[j]!=0) //是否处于间隔时间
ans=ans+f[j]-ans%f[j];
ans+=c[j];
}
printf("%d\n",ans);
}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: