您的位置:首页 > 产品设计 > UI/UE

HDU - 1509 Windows Message Queue (优先队列 重载运算符)

2017-12-28 09:13 375 查看
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by.
There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET

PUT msg1 10 5

PUT msg2 10 4

GET

GET

GET

Sample Output

EMPTY QUEUE!

msg2 10

msg1 10

EMPTY QUEUE!

题意:输入GET的时候输出队首元素,如果没有则为空,输入PUT则压人元素 ,队列排列的方法:优先级越小的越靠前,优先级一样则谁先出现谁靠前

思路:利用优先队列小根堆排序(优先队列默认的是大根堆排序)

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
typedef long long ll;
#define N 1005
using namespace std;
struct Msg{
string contain;
int argc,value,order;
friend bool operator<(const Msg m1,const Msg m2)
{
if(m1.value!=m2.value)
return m1.value>m2.value;
else
return m1.order>m2.order;
}
}mm;
priority_queue <Msg> a;
int main()
{
string in;
int ipos=0;
while(cin>>in){
if(in=="GET"){
if(a.empty())
cout<<"EMPTY QUEUE!"<<endl;
else
{
cout<<a.top().contain<<" "<<a.top().argc<<endl;
a.pop();
}
}
else{
cin>>mm.contain>>mm.argc>>mm.value;
mm.order=ipos++;
a.push(mm);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: