您的位置:首页 > 编程语言 > PHP开发

Hdoj 1092 A+B for Input-Output Practice (IV)

2017-12-21 21:10 686 查看
Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4

5 1 2 3 4 5

0

Sample Output

10

15

题目分析

输出每行的和

Code

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n==0) break;
else
{
int sum=0;
int temp;
for(int i=1;i<=n;i++)
{
cin>>temp;
sum+=temp;
}
cout<<sum<<endl;
}
}
return 0;
}


更多问题请关注个人博客,不定时更新
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: