您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之查找一:二叉排序树

2017-12-21 19:58 267 查看
数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。

简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。

Example Input

4 2

3 1 4 2

3 4 1 2

3 2 4 1

2 1

2 1

1 2

0

Example Output

Yes

No

No

Hint

Author

xam

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
int cnt,n;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat(struct node *tree,int x)
{
if(tree == NULL)
{
tree = (struct node *)malloc(sizeof(struct node));
tree -> data = x;
tree -> lchild = NULL;
tree -> rchild = NULL;
}
else
{
if(x > tree->data)
{
tree -> rchild = creat(tree->rchild,x);
}
else tree -> lchild = creat(tree->lchild,x);
}
return tree;
}
void judge(struct node *t1,struct node *t2)
{
if(t1&&t2)
{
if(t1->data != t2 -> data)
{
cnt = 1;
return;
}
judge(t1->lchild,t2->lchild);
judge(t1->rchild,t2->rchild);

}
}
int main()
{
int l,i,x;
while(~scanf("%d %d",&n,&l)&&n!=0)
{
struct node *root = NULL;
for(i = 0;i < n;i++)
{
scanf("%d",&x);
root = creat(root,x);
}
while(l--)
{
struct node *T1 = NULL;//注意每次建树都得初始化;
for(i = 0;i < n;i++)
{
scanf("%d",&x);
T1 = creat(T1,x);
}
cnt = 0;
judge(root,T1);
if(cnt==1)cout<<"No"<<endl;
else cout<<"Yes"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构