您的位置:首页 > 其它

Hdoj 2070 Fibbonacci Number

2017-12-20 13:59 141 查看
Problem Description

Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0

f(1) = 1

f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input

Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.

Output

Print out the answer in a single line for each test case.

Sample Input

3

4

5

-1

Sample Output

2

3

5

Hint

Note:

you can use 64bit integer: __int64

Author

Lily

Source

浙江工业大学网络选拔赛

题目分析

斐波那契数列问题,用__int64即可

Code

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<cstring>
#include<cstdlib>
using namespace std;
__int64 a[51];
int main()
{
int n;
cin>>n;
a[0]=0;a[1]=1;
for(int i=2;i<=50;i++) a[i]=a[i-1]+a[i-2];
while(n!=-1)
{
cout<<a
<<endl;
cin>>n;
}
return 0;
}


更多问题请关注个人博客,不定时更新
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: