您的位置:首页 > 其它

POJ 2253 Frogger

2017-12-20 13:32 253 查看
Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 51252 Accepted: 16274
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


题目大意:给出两个青蛙的x,y坐标和其他石头的坐标,求出所有路径中权值最大的最小值

需要修改一下松弛条件

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=210;
double dis[maxn];
bool vis[maxn];
int n;
struct Node{
int x,y;
}map[maxn];
double mmp[maxn][maxn];
double init(Node a,Node b){
double x=(a.x-b.x)*(a.x-b.x);
double y=(a.y-b.y)*(a.y-b.y);
return sqrt(x+y);
}
void dijkstra(){
for(int i=1;i<=n;i++) dis[i]=mmp[1][i];
memset(vis,false,sizeof(vis));
dis[1]=0;
vis[1]=true;
for(int i=0;i<n;i++){
double minn=0x3f3f3f3f+0.5;
int flag;
for(int j=1;j<=n;j++){
if(!vis[j]&&dis[j]<minn){
minn=dis[j];
flag=j;
}
}
vis[flag]=true;
for(int j=1;j<=n;j++){
if(!vis[j]){
if(dis[j]>max(dis[flag],mmp[flag][j])){
dis[j]=max(dis[flag],mmp[flag][j]);
}
}
}
}
}
int main(){
int cnt=1;
while(cin>>n){
if(!n) break;
for(int i=1;i<=n;i++){
cin>>map[i].x>>map[i].y;
}
for(int i=1;i<=n;i++){
for(int j=i+1;j<=n;j++){
mmp[i][j]=mmp[j][i]=init(map[i],map[j]);
}
}
dijkstra();
printf("Scenario #%d\n",cnt++);
printf("Frog Distance = %.3f\n\n",dis[2]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: