您的位置:首页 > 其它

2017 CCPC 秦皇岛 & ZOJ 3981 - Balloon Robot 规律

2017-12-19 23:14 489 查看
Balloon Robot
Time Limit: 1 Second      Memory Limit: 65536 KB

The 2017 China Collegiate Programming Contest Qinhuangdao Site is coming! There will be  teams
participating in the contest, and the contest will be held on a huge round table with  seats
numbered from 1 to  in
clockwise order around it. The -th
team will be seated on the -th
seat.
BaoBao, an enthusiast for competitive programming, has made  predictions
of the contest result before the contest. Each prediction is in the form of ,
which means the -th
team solves a problem during the -th
time unit.
As we know, when a team solves a problem, a balloon will be rewarded to that team. The participants will be u
4000
nhappy if the balloons take almost centuries to come. If a team solves a problem
during the -th
time unit, and the balloon is sent to them during the -th
time unit, then the unhappiness of the team will increase by .
In order to give out balloons timely, the organizers of the contest have bought a balloon robot.
At the beginning of the contest (that is to say, at the beginning of the 1st time unit), the robot will be put on the -th
seat and begin to move around the table. If the robot moves past a team which has won themselves some balloons after the robot's last visit, it will give all the balloons they deserve to the team. During each unit of time, the following events will happen in
order
:
The robot moves to the next seat. That is to say, if the robot is currently on the -th
()
seat, it will move to the ()-th
seat; If the robot is currently on the -th
seat, it will move to the 1st seat.
The participants solve some problems according to BaoBao's prediction.
The robot gives out balloons to the team seated on its current position if needed.
BaoBao is interested in minimizing the total unhappiness of all the teams. Your task is to select the starting position  of
the robot and calculate the minimum total unhappiness of all the teams according to BaoBao's predictions.

Input

There are multiple test cases. The first line of the input contains an integer ,
indicating the number of test cases. For each test case:
The first line contains three integers ,  and  (, , ),
indicating the number of participating teams, the number of seats and the number of predictions.
The second line contains  integers  (,
and  for
all ),
indicating the seat number of each team.
The following  lines
each contains two integers  and  (, ),
indicating that the -th
team solves a problem at time  according
to BaoBao's predictions.
It is guaranteed that neither the sum of  nor
the sum of  over
all test cases will exceed .

Output

For each test case output one integer, indicating the minimum total unhappiness of all the teams according to BaoBao's predictions.

Sample Input

4
2 3 3
1 2
1 1
2 1
1 4
2 3 5
1 2
1 1
2 1
1 2
1 3
1 4
3 7 5
3 5 7
1 5
2 1
3 3
1 5
2 5
2 100 2
1 51
1 500
2 1000

Sample Output

1
4
5
50

Hint

For the first sample test case, if we choose the starting position to be the 1st seat, the total unhappiness will be (3-1) + (1-1) + (6-4) = 4. If we choose the 2nd seat, the total unhappiness
will be (2-1) + (3-1) + (5-4) = 4. If we choose the 3rd seat, the total unhappiness will be (1-1) + (2-1) + (4-4) = 1. So the answer is 1.
For the second sample test case, if we choose the starting position to be the 1st seat, the total unhappiness will be (3-1) + (1-1) + (3-2) + (3-3) + (6-4) = 5. If we choose the 2nd seat,
the total unhappiness will be (2-1) + (3-1) + (2-2) + (5-3) + (5-4) = 6. If we choose the 3rd seat, the total unhappiness will be (1-1) + (2-1) + (4-2) + (4-3) + (4-4) = 4. So the answer is 4.
Author: WENG, Caizhi
Source: The 2017 China Collegiate Programming Contest, Qinhuangdao Site

可以写一下机器从1 2 3 开始 各个气球点的等待时代,发现是每次-1 -1,0就变为m。

那么就假设从1开始,得到每个气球的等待数组d。

给d排个序,用重复的只要算一次。 让i这个点等于0(即减了d[i]),那么i前面的点都加了m。所以的点都减了d[i]。就可以遍历一次答案,取最小。

#include <iostream>
#include <string>
#include <string.h>
#include <math.h>
#include <vector>
#include <map>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn = 2e5+33;
#define LL long long
LL pos[maxn];
LL d[maxn];
int main()
{
LL T;
scanf("%lld",&T);
while(T--){
LL n,m,p;
scanf("%lld %lld %lld",&n,&m,&p);
for(LL i=1;i<=n;i++){
LL x;scanf("%lld",&x);
pos[i]=x;
}
LL ans = 0;
for(LL i=1;i<=p;i++){
LL a,b;
scanf("%lld %lld",&a,&b);
b=b%m;
if(b==0) b=m;
d[i]=(pos[a]-b+m)%m;
ans+=d[i];
}
sort(d+1,d+1+p);
d[0]=-1;
LL aim=999999999999999999;
for(LL i=1;i<=p;i++){
if(d[i]!=d[i-1]){
aim=min(aim,(i-1)*m+ans-p*d[i]);
}
}
printf("%lld\n",aim);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: