您的位置:首页 > 产品设计 > UI/UE

HDU 1159 Common Subsequence (dp)

2017-12-19 15:00 211 查看


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 42749    Accepted Submission(s): 19708


Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

 

Sample Output

4
2
0

 
用线性dp发现会出现错误 aa  a两个数列答案是 2

错误代码:#include <stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main(int argc, char *argv[])
{
char a[1001],b[1001];
while(scanf("%s %s",a,b)!=EOF)
{
int dp[1001]={0};
int i,j,k;
int len1=strlen(a);
int len2=strlen(b);
for(i=0;i<len2;i++)
{
for(j=0;j<len1;j++)
{
if(b[i]==a[j])
{
dp[j]=1;
for(k=j-1;k>=0;k--)
{
dp[j]=max(dp[j],dp[k]+1);
}
4000
}
}
}
int max1=0;
for(i=0;i<len1;i++)
{
max1=max(dp[i],max1);
}
printf("%d\n",max1);
}
return 0;
}所以用矩阵类dp 
#include <stdio.h>
#include<string.h>
int dp[1010][1010];
int main(int argc, char *argv[])
{
int i,j;
char a[1000],b[1000];
while(scanf("%s %s",a,b)!=EOF)
{
int len1,len2;
len1=strlen(a);
len2=strlen(b);
for(i=0;i<=len1;i++)
{
dp[0][i]=0;
}
for(i=0;i<=len2;i++)
{
dp[i][0]=0;
}
for(i=1;i<=len1;i++)
{
for(j=1;j<=len2;j++)
{
if(a[i-1]==b[j-1])
{
dp[i][j]=dp[i-1][j-1]+1;
}
else
{
if(dp[i][j-1]>dp[i-1][j])
{
dp[i][j]=dp[i][j-1];
}
else
{
dp[i][j]=dp[i-1][j];
}
}
}
}
printf("%d\n",dp[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: