您的位置:首页 > 其它

PAT 1010. Radix(25)

2017-12-14 22:47 375 查看
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag"
is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10

Sample Output 1:
2

Sample Input 2:
1 ab 1 2

Sample Output 2:

Impossible

#include<iostream>
#include<iomanip>
#include<string>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;

string a[3];
long long int tag,radix;
long long int num1;
long long int tolongint(string s,long long int dig)
{
long long int ans=0;
long long int d=1;
for(int i=s.size()-1;i>=0;i--)
{
int num;
if(s[i]>='0'&&s[i]<='9')
num=s[i]-'0';
else
num=s[i]-'a'+10;
ans=ans+num*d;
d*=dig;
}
return ans;
}

int cmp(string s,long long int dig)
{
long long int ans=0;
long long int d=1;
for(int i=s.size()-1;i>=0;i--)
{
int num;
if(s[i]>='0'&&s[i]<='9')
num=s[i]-'0';
else
num=s[i]-'a'+10;
ans = ans+num*d;
if(ans>num1)
return 1;
d*=dig;
}
if(ans == num1) return 0;
return -1;
}
int Maxnum(string s)
{
int d=-1;
for(int i=0;i<s.size();i++)
{
int num;
if(s[i]>='0'&&s[i]<='9')
num=s[i]-'0';
else
num=s[i]-'a'+10;
if(num>d)
d=num;
}
return d+1;
}
long long int Max(long long int a,long long int b)
{
return a>b?a:b;
}
long long int BinarySearch(int cur)
{
long long int L=Maxnum(a[cur]);
long long int R=Max(L,num1),M;
while(L<=R)
{
M=(L+R)/2;
int res=cmp(a[cur],M);
if(res==0) return M;
else if(res==1) R=M-1;
else L=M+1;
}
return -1;
}
int main()
{
while(cin>>a[1]>>a[2]>>tag>>radix)
{
if(a[1]=="1"&&a[2]=="1")
{
cout<<"2"<<endl;
continue;
}
if(a[1]==a[2])
{
cout<<radix<<endl;
continue;
}
num1=tolongint(a[tag],radix);
int cur;
if(tag==1) cur=2;
else cur=1;
long long int ans=BinarySearch(cur);
if(ans==-1) cout<<"Impossible"<<endl;
else
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: