您的位置:首页 > 其它

ZOJ 1006 Do the Untwist

2017-12-13 23:18 465 查看
Cryptography deals with methods of secret communication that transform a message (theplaintext) into a disguised form (the
ciphertext) so that no one seeing the ciphertext will be able to figure out the plaintext except the intended recipient. Transforming the plaintext to the ciphertext isencryption; transforming the ciphertext
to the plaintext isdecryption. Twisting is a simple encryption method that requires that the sender and recipient both agree on a secret keyk, which is a positive integer.

The twisting method uses four arrays: plaintext and ciphertext are arrays of characters, andplaincode and
ciphercode are arrays of integers. All arrays are of lengthn, where
n is the length of the message to be encrypted. Arrays are origin zero, so the elements are numbered from 0 ton
- 1. For this problem all messages will contain only lowercase letters, the period, and the underscore (representing a space).

The message to be encrypted is stored in plaintext. Given a key k, the encryption method works as follows. First convert the letters inplaintext to integer codes in
plaincode according to the following rule: '_' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26, and '.' = 27. Next, convert each code inplaincode to an encrypted code in
ciphercode according to the following formula: for alli from 0 to
n - 1,

ciphercode[i] = (plaincode[ki modn]
- i) mod 28.
(Here x mod y is the positive remainder when x is divided byy. For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. You can use the C '%' operator or Pascal 'mod' operator to compute this as long
as you addy if the result is negative.) Finally, convert the codes in
ciphercode back to letters inciphertext according to the rule listed above. The final twisted message is inciphertext. Twisting the message
cat using the key 5 yields the following:

Array012
plaintext'c''a''t'
plaincode3120
ciphercode31927
ciphertext'c''s''.'
Your task is to write a program that can untwist messages, i.e., convert the ciphertext back to the original plaintext given the keyk. For example, given the key 5 and ciphertext 'cs.', your program must output the plaintext
'cat'.

The input file contains one or more test cases, followed by a line containing only the number 0 that signals the end of the file. Each test case is on a line by itself and consists of the keyk, a space, and then a twisted message containing at least
one and at most 70 characters. The keyk will be a positive integer not greater than 300. For each test case, output the untwisted message on a line by itself.

Note: you can assume that untwisting a message always yields a unique result. (For those of you with some knowledge of basic number theory or abstract algebra, this will be the case provided that the greatest common divisor of the keyk
and length n is 1, which it will be for all test cases.)

Example input:

5 cs.
101 thqqxw.lui.qswer
3 b_ylxmhzjsys.virpbkr
0

Example output:

cat
this_is_a_secret
beware._dogs_barking


Source: Zhejiang University Local Contest 2001
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
int k,n;char o[100];
int A[100],B[100];
int main()
{
int a,b,c;
scanf("%d",&k);
while(k!=0)
{
memset(A,0,sizeof(A));
memset(B,0,sizeof(B));
scanf("%s",o);
for(n=0;o
!='\0';n++);
for(a=0;a<n;a++)
{
if(o[a]=='.')A[a]=27;
else if(o[a]=='_')A[a]=0;
else A[a]=o[a]-'a'+1;
}
for(a=0;a<n;a++)B[k*a%n]=((A[a]+a)%28+28)%28;
for(a=0;a<n;a++)
{
if(B[a]==0)putchar('_');
else if(B[a]==27)putchar('.');
else putchar('a'+B[a]-1);
}
putchar('\n');
scanf("%d",&k);
}
return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  zoj 模拟