您的位置:首页 > 其它

HDOJ1563 Find your present!

2017-12-12 22:51 239 查看

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4440    Accepted Submission(s): 2936


[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from
all the others.
 

[align=left]Input[/align]
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.
 

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0

 

[align=left]Sample Output[/align]

3
2

 HDOJ2095也是Find your present!  但这个是简单版的。
2095主要是数据量比较大,java的话需要使用快速输入输出的方式,这里就不需要了。
题目意思是一样的:http://blog.csdn.net/qq_38238041/article/details/78536304

import java.util.Scanner;

public class Main{
private static Scanner scanner;

public static void main(String[] args) {
scanner = new Scanner(System.in);
while (scanner.hasNext()) {
int n = scanner.nextInt();
if (n == 0) {
return;
}
int res = 0;
while(n-->0){
int i = scanner.nextInt();
res = res^i;
}
System.out.println(res);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: