您的位置:首页 > 其它

《挑战程序设计江赛》P18 题目:Ants POJ 1852 需要想象力的模拟

2017-12-11 07:45 399 查看
Poj 1852 题目链接:http://poj.org/problem?id=1852
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 20836 Accepted: 8598
DescriptionAn army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.InputThe first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.OutputFor each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. Sample Input2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output4 8
38 207
SourceWaterloo local 2004.09.19
#include <iostream>

using namespace std;
int x[1000000];

int main()
{
int k;
cin>>k;
for(int i=1;i<=k;i++){
int L;
int n;
cin>>L>>n;
for(int i=0;i<n;i++){

cin>> x[i];
}

int my_Min=0;
for(int i=0;i<n;i++){

my_Min=  max( my_Min, min( x[i], L-x[i] ) );  //注意这里是max

}

int my_Max=-1;
for(int i=0;i<n;i++){

my_Max =max( my_Max, max( x[i], L-x[i] ) );
}
cout << my_Min << " " << my_Max<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: