您的位置:首页 > 其它

poj 3069 Saruman's Army

2017-12-10 21:24 330 查看

Saruman's Army

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of
R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of
his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer
R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer
n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions
x1, …, xn of each troop (where 0 ≤
xi ≤ 1000). The end-of-file is marked by a test case with
R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

这道题让我意识到仔细读题的重要性,读题花再长的时间也不亏。

这道题时刻要想着插眼之后,这个眼的左右,插完眼之后要考虑此刻哪些士兵没有被标记。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
int a[1100];
int r, n;
while(scanf("%d %d", &r, &n) != EOF)
{
if(r == -1&&n == -1)
break;
memset(a,-1,sizeof(a));
for(int i = 1; i <= n; i ++)
{
scanf("%d", &a[i]);
}
sort(a + 1, a + n + 1);
int cnt = 0;
int x = 1;
int s = 1;
while(x <= n)
{
int tem = x;
while(a[s] + r >= a[x]&&x <= n)
x ++;
if(tem == x)
{
if(a[x] != a[x + 1])
cnt ++;
x ++;
s = x;
continue;
}
int load = x - 1;
while(a[load] + r >= a[x] && x <= n)
x ++;
s = x;
cnt ++;
// printf("x = %d, a[%d] = %d, cnt = %d load = %d\n", x, x, a[x], cnt, a[x - 1]);
}
printf("%d\n", cnt);
}

return 0;
}这个算法把r = 0列出来了,但是仔细想想,如果改成下面算法,就会把r = 0普遍化。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
int a[1100];
int r, n;
while(scanf("%d %d", &r, &n) != EOF)
{
if(r == -1&&n == -1)
break;
memset(a,-1,sizeof(a));
for(int i = 1; i <= n; i ++)
{
scanf("%d", &a[i]);
}
sort(a + 1, a + n + 1);
int cnt = 0;
int x = 1;
int s = 1;
while(x <= n)
{
x ++;
while(a[s] + r >= a[x]&&x <= n)
x ++;
int load = x - 1;
while(a[load] + r >= a[x] && x <= n)
x ++;
s = x;
cnt ++;
// printf("x = %d, a[%d] = %d, cnt = %d load = %d\n", x, x, a[x], cnt, a[x - 1]);
}
printf("%d\n", cnt);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: