您的位置:首页 > 其它

Hie with the Pie (状态dp)

2017-12-10 20:02 148 查看
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer
n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be
n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the
n locations (numbers 1 to n). The jth value on the
ith line indicates the time to go directly from location i to location
j without visiting any other locations along the way. Note that there may be quicker ways to go from
i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location
i to j may not be the same as the time to go directly from location
j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output
8


题目大概:

要给很多店从东西,从一个店到另一个店时间不一样,最后要回到比萨饼店。问最短时间是多少。

思路:

先用弗洛伊德算出最短路径

然后

状态dp。

dp【i】【j】状态  i  的时候到达了 j  店的最短时间

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int ma=11;
int dp[1<<ma][11];
int col[ma][ma];

int main()
{
int n;
while(~scanf("%d",&n))
{
if(n==0)break;

memset(dp,0,sizeof(dp));
for(int i=0;i<=n;i++)
{

for(int j=0;j<=n;j++)
{

scanf("%d",&col[i][j]);
}
}
for(int k=0;k<=n;k++)
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
col[i][j]=min(col[i][k]+col[k][j],col[i][j]);//弗洛伊德最短路径

int cnt=1<<n;

for(int j=1;j<cnt;j++)//枚举所有状态
{

for(int r1=0;r1<=n;r1++)//枚举到达的店
{
int tem=(1<<(r1-1));
if(tem&j)//给店要合法
{
if(tem==j)dp[j][r1]=col[0][r1];//可能只有第一个店
else{
dp[j][r1]=0x3f3f3f;
for(int i=1;i<=n;i++)//或者是从其他店来到本店
{
if(i!=r1&&j&(1<<(i-1)))//该店不能r1重复,并且要在状态内。
dp[j][r1]=min(dp[j][r1],dp[j^(1<<(r1-1))][i]+col[i][r1]);
}
}
}

}
}

int ans=dp[(1<<n)-1][1]+col[1][0];
for(int i=2;i<=n;i++)
if(ans>dp[(1<<n)-1][i]+col[i][0])
ans=dp[(1<<n)-1][i]+col[i][0];
printf("%d\n",ans);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息