您的位置:首页 > 其它

HDU 1712 ACboy needs your help (分组背包)

2017-12-09 16:23 309 查看
Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2

1 2

1 3

2 2

2 1

2 1

2 3

3 2 1

3 2 1

0 0

Sample Output

3

4

6

大致题意:一个人有n门课,准备在m天内学习这些课,然后给你一个n*m的矩阵,a[i][j]表示第i门课学习j天的收益,一天只能学习一门课,问最大收益多少。

思路:比较裸的分组背包

代码如下

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;
#define LL long long int
int a[105][105];
int dp[105];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(!(n+m)) break;
memset(dp,0,sizeof dp);
for(
4000
int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&a[i][j]);
for(int i=1;i<=n;i++)//i组
for(int j=m;j>=0;j--)
for(int k=1;k<=m;k++)
if(j-k>=0)
{
dp[j]=max(dp[j],dp[j-k]+a[i][k]);
}
printf("%d\n",dp[m]);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: