您的位置:首页 > 其它

HDU-1358 - Period - KMP

2017-12-09 01:50 399 查看

链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=1358

题目:

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

题意:

  给一字符串,求其所有完整循环的前缀与循环节的长度。

  例:
aaa
,长度2前缀,循环节为a,个数为2 ,长度3前缀,循环节为a,个数为3。

思路:

  跑一下字符串next数组的预处理,得出循环节的长度为
len - len % next[len]
,如果len%循环节长度为0,则说明是完整循环,输出解。

实现:

#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = int(2e7)+7;
char p[maxn];
int jump[maxn], m;
void process() {
jump[0] = 0;
for(int i = 1, j = 0 ; i < m ; i++) {
while(j > 0 && p[i] != p[j]) j = jump[j-1];
if(p[i] == p[j]) j++;
jump[i] = j;
}
}
int main() {
int cas = 1;
while(scanf("%d", &m), m > 0) {
scanf(" %s", p);
process();
printf("Test case #%d\n", cas++);
for(int i=1 ; i<m ; i++) {
int n = i-jump[i]+1;
if((i+1)%n == 0 && n!=i+1) {
printf("%d %d\n", i+1, (i+1)/n);
}
}
putchar('\n');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp hdu 1358 题解