您的位置:首页 > 其它

HDOJ1390 Binary Numbers

2017-12-08 15:19 357 查看

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6079    Accepted Submission(s): 3690


[align=left]Problem Description[/align]
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

 

[align=left]Input[/align]
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

[align=left]Output[/align]
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

 

[align=left]Sample Input[/align]

1
13

 

[align=left]Sample Output[/align]

0 2 3

 将一个十进制正整数转换为二进制数,输出二进制数的1的位置。
比如13:1101,然后位置应该是从右到左的:0 2 3.
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {
private static Scanner scanner;

public static void main(String[] args) {
scanner = new Scanner(System.in);
int cases = scanner.nextInt();
while (cases-- > 0) {
int n = scanner.nextInt();
String string = Integer.toBinaryString(n);
// System.out.println(string);
List<Integer> list = new ArrayList<Integer>();
int len = string.length();
for (int i = 0, j = len - 1; i < len && j >= 0; j--, i++) {//注意这里的i是位置,而j是二进制字符串的指针
if (string.charAt(j) == '1') {
list.add(i);
}
}
if (list.size() > 0) {
System.out.print(list.get(0));
for (int i = 1; i < list.size(); i++) {
System.out.print(" " + list.get(i));
}
System.out.println();
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: