您的位置:首页 > 其它

HDU 1072 - Nightmare(BFS)

2017-12-07 16:32 369 查看
2017.12.6对BFS系列练习的第四题。

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1072

Nightmare

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12544 Accepted Submission(s): 6131

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

1. We can assume the labyrinth is a 2 array.

2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.

3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.

4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.

5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.

6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.

There are five integers which indicate the different type of area in the labyrinth:

0: The area is a wall, Ignatius should not walk on it.

1: The area contains nothing, Ignatius can walk on it.

2: Ignatius’ start position, Ignatius starts his escape from this position.

3: The exit of the labyrinth, Ignatius’ target position.

4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

Sample Output

4

-1

13

这道题好玩的地方是,无论什么时候,只要时间归零,那么做什么都没有用了。所以要在每个结构体中存炸弹还剩的时间,如果剩了一秒,没走到重置器或者终点上就放弃这条路线。这道题还有一个判重的要点就是:一个重置器最多只能用一次,用多了就算重。(可以仔细思考一下为什么)我就是在这里RE了3次。。

AC代码如下:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 10;
int n, m;
int sx, sy;
int la[maxn][maxn];
int vis[maxn][maxn];
struct Node{
int x, y;
int min;
int t;
};
int dx[4] = {0, 0, 1, -1};
int dy[4] = {1, -1, 0, 0};

int BFS()
{
queue<Node> I;
memset(vis, 0, sizeof(vis));
Node beg;
beg.x = sx, beg.y = sy, beg.t = 6, beg.min = 0;
I.push(beg);

while(!I.empty())
{
Node cur = I.front();
while((!I.empty()) && cur.t <= 1)
{
I.pop();
cur = I.front();
if(la[cur.x][cur.y] == 3 && cur.t)    return cur.min;
}
I.pop();
if(la[cur.x][cur.y] == 3 && cur.t)    return cur.min;

for(int i = 0; i < 4; i++)
{
Node next;
next.x = cur.x + dx[i];
next.y = cur.y + dy[i];
next.t = cur.t - 1;
next.min = cur.min + 1;

if(next.x < 0 || next.x >= n || next.y < 0 || next.y >= m)    continue;
if(!la[next.x][next.y])    continue;
if(vis[next.x][next.y])    continue;

if(la[next.x][next.y] == 4)
{
next.t = 6;
vis[next.x][next.y] = 1;
}
if(la[next.x][next.y] == 3 && next.t)    return next.min;
if(next.t <= 1)    continue;
I.push(next);
}
}
return -1;
}
int main()
{
int kase;
scanf("%d", &kase);
while(kase--)
{
scanf("%d %d", &n, &m);
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
{
scanf("%d", &la[i][j]);
if(la[i][j] == 2)
{
sx = i;
sy = j;
}
}
printf("%d\n", BFS());
}
return 0
a8e3
;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: