您的位置:首页 > 其它

1068. Find More Coins (30) 01背包

2017-12-07 16:32 471 查看


1068. Find More Coins (30)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each
bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for
it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second
line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 +
... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution"
instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].
Sample Input 1:
8 9
5 9 8 7 2 3 4 1

Sample Output 1:
1 3 5

Sample Input 2:
4 8
7 2 4 3

Sample Output 2:
No Solution


思路:01背包问题,因为要输出从小到大的排列,可以先把硬币面额从大到小排列,用bool类型chose[i][j]表示背包容量为j有i个物品选不选,dp存储不同背包容量时可以凑出的最大金额,如果dp[M]==M则说明有解

#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;
int N,M,sz[10001],dp[101];
bool chose[10001][101];
vector<int>ans;
bool cmp(int a,int b){
return a>b;
}
int main(){
scanf("%d %d",&N,&M);
for(int i=1;i<=N;i++){
scanf("%d",&sz[i]);
}
sort(sz+1,sz+1+N,cmp);
for(int i=1;i<=N;++i){
for(int j=M;j>=sz[i];j--){
if(dp[j-sz[i]]+sz[i]>=dp[j]){
dp[j]=dp[j-sz[i]]+sz[i];
chose[i][j]=true;
}
}
}
if(dp[M]!=M) printf("No Solution");
else{
int index=N;
while(M!=0){
if(chose[index][M]){
ans.push_back(sz[index]);
M-=sz[index];
}
index--;
}
for(int i=0;i<ans.size();i++){
printf("%d%c",ans[i],i==ans.size()-1?'\n':' ');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: