您的位置:首页 > 其它

LC-Display

2017-12-07 15:23 337 查看
A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so
much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input

The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 ≤ s ≤ 10, 0 ≤ n ≤ 99,999,999), where n is the number to be displayed and s is the size in which it shall be displayed.

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output

Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the
digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits.

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input

2 12345
3 67890
0 0


Sample Output

--   --        --
|    |    | |  | |
|    |    | |  | |
--   --   --   --
| |       |    |    |
| |       |    |    |
--   --        --

---   ---   ---   ---   ---
|         | |   | |   | |   |
|         | |   | |   | |   |
|         | |   | |   | |   |
---         ---   ---
|   |     | |   |     | |   |
|   |     | |   |     | |   |
|   |     | |   |     | |   |
---         ---   ---   ---


#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int main()
{
    int s;
    while(cin>>s)
    {
        char n[9];
        cin>>n;
        if(s==0&&n[0]=='0')
        {break;}
        int longth=strlen(n);
        int list[9];
        for(int a=0;a<longth;a++)
        {list[a]=n[a]-'0';}
        for(int i=1;i<=s+s+3;i++)
        {
            if(i==1||(i==s+2)||(i==s*2+3))
            {
                for(int z=0;z<longth;z++)
                {
                    if(list[z]==1||((list[z]==4)&&(i!=s+2))||(list[z]==7&&i!=1)||(list[z]==0&&i==s+2))
                    {for(int fuck=0;fuck<s+2;fuck++)
                        {cout<<" ";}}
                    else
                    {
                        cout<<" ";
                        for(int c=1;c<=s;c++)
                        {cout<<"-";}
                        cout<<" ";
                    }
                    if(z<longth-1)
                    {cout<<" ";}
                }
            }
            else
            {
                for(int z=0;z<longth;z++)
                {
                    if(((list[z]==4)&&(i<s+2))||((list[z]==6)&&(i>s+2))||(list[z]==8)||((list[z]==9)&&(i<s+2))||list[z]==0)
                    {
                        cout<<"|";
                        for(int fuck=0;fuck<s;fuck++)
                        {cout<<" ";}
                        cout<<"|";
                    }
                    else if(((list[z]==2)&&(i>s+2))||((list[z]==5)&&(i<s+2))||(list[z]==6&&i<s+2))
                    {
                        cout<<"|";
                        for(int fuck=0;fuck<s+1;fuck++)
                        {cout<<" ";}
                    }
                    else
                    {
                        for(int fuck=0;fuck<s+1;fuck++)
                        {cout<<" ";}
                        cout<<"|";
                    }
                    if(z<longth-1)
                    {cout<<" ";}
                }
            }
            cout<<endl;
        }
        cout<<endl;
    }
    return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息