您的位置:首页 > 其它

poj 3280 Cheapest Palindrome

2017-12-07 10:08 337 查看
Cheapest Palindrome

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11101 Accepted: 5295
Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of
inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated
costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 

Line 2: This line contains exactly M characters which constitute the initial ID string 

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
4000
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
Source

USACO 2007 Open Gold

一个经典的区间dp。。

思路:dp[i][j]代表区间i到区间j成为回文串的最小代价,那么对于dp[i][j]有三种情况:

1、dp[i+1][j]表示区间i到区间j已经是回文串了的最小代价,那么对于s[i]这个字母,我们有两种操作,删除与添加,对应有两种代价,dp[i+1][j]+add[s[i]],dp[i+1][j]+del[s[i]],取这两种代价的最小值;

2、dp[i][j-1]表示区间i到区间j-1已经是回文串了的最小代价,那么对于s[j]这个字母,同样有两种操作,dp[i][j-1]+add[s[j]],dp[i][j-1]+del[s[j]],取最小值

3、若是s[i]==s[j],dp[i+1][j-1]表示区间i+1到区间j-1已经是回文串的最小代价,那么对于这种情况,我们考虑dp[i][j]与dp[i+1][j-1]的大小........

#include <iostream>
#include <string>
#include <algorithm>
#include <string.h>
using namespace std;
int dp[2050][2050], del[300], add[300];
int n, m;
int main() {
//freopen("in.txt", "r", stdin);
memset(dp, 0, sizeof(dp));
cin >> n >> m;
string str;
cin >> str;
char ch;
int a, b;
for (int i = 0; i < n; ++i) {
cin >> ch >> a >> b;
add[ch] = a;
del[ch] = b;
}
//dp[i][j] 表示i 到 j为花费最小的回文串
//以j为结尾。
//从i到j范围的dp
for (int j = 0; j < m; ++j) {
for (int i = j; i >= 0; --i) {
//删掉第i个或者从右边加上一个str[i]
dp[i][j] = min(dp[i + 1][j] + del[str[i]], dp[i + 1][j] + add[str[i]]);
//同上
dp[i][j] = min(dp[i][j], min(dp[i][j - 1] + del[str[j]], dp[i][j - 1] + add[str[j]]));
if (str[i] == str[j])
dp[i][j] = min(dp[i][j], dp[i + 1][j - 1]);
}
}
cout << dp[0][m - 1] << endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: