您的位置:首页 > 编程语言 > C语言/C++

B - Saruman's Army(贪心 最少圆覆盖)

2017-12-06 21:59 225 查看
Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range ofR units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within
R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integerR, the maximum effective range of all palantirs (where 0 ≤
R ≤ 1000), and an integern, the number of troops in Saruman’s army (where 1 ≤
n ≤ 1000). The next line contains n integers, indicating the positionsx1, …,
xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case withR =
n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:给你一条直线上n个点,求以最少圆覆盖所有点的圆的数目,圆的半径已知,圆心在给出的点上

贪心嘛,自然想要每个圆覆盖到的点最多,先把输入的点sort一下(排序)

所以第一个点肯定不是圆心,圆心应该在距离第一个点最远(小于圆的半径)的点上,

找到圆心后,我们再向后找出这个圆覆盖到的范围,从下一个未被覆盖的点重新进行以上操作,以此类推。

代码如下

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int point[100005]={0},r,n,i;
while(6)
{
memset(point,0,sizeof(point));//清空point
scanf("%d%d",&r,&n);
if(r==-1)
break;
for(i=0;i<n;i++)
scanf("%d",&point[i]);

sort(point,point+n);

int sum=0,temp=point[0];

for(i=0;i<n;)
{

while(temp+r>=point[i] && i<n)i++;

temp=point[i-1];

while(temp+r>=point[i] && i<n)i++;

temp=point[i];

sum++;
}
printf("%d\n",sum);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 acm