您的位置:首页 > 理论基础 > 数据结构算法

POJ-3264 Balanced Lineup (线段树 基本题)

2017-12-05 19:41 351 查看
Balanced Lineup

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 57981 Accepted: 27169
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest
cow in the group.

Input

Line 1: Two space-separated integers, N and Q. 

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
#define maxn 50001
int c[maxn << 2][2];
void add(int o, int l, int r, int id, int v){
if(l == r){
c[o][0] = c[o][1] = v;
return;
}
int mid = l + r >> 1;
if(id <= mid) add(o << 1, l, mid, id, v);
if(id > mid) add(o << 1 | 1, mid + 1, r, id, v);
c[o][0] = min(c[o << 1][0], c[o << 1 | 1][0]);
c[o][1] = max(c[o << 1][1], c[o << 1 | 1][1]);
}
int queryMin(int o, int l, int r, int L, int R){
if(l >= L && r <= R){
return c[o][0];
}
int mid = l + r >> 1, ans = 1e9;
if(mid >= L) ans = min(ans, queryMin(o << 1, l, mid, L, R));
if(mid < R) ans = min(ans, queryMin(o << 1 | 1, mid + 1, r, L, R));
return ans;
}
int queryMax(int o, int l, int r, int L, int R){
if(l >= L && r <= R){
return c[o][1];
}
int mid = l + r >> 1, ans = 0;
if(mid >= L) ans = max(ans, queryMax(o << 1, l, mid, L, R));
if(mid < R) ans = max(ans, queryMax(o << 1 | 1, mid + 1, r, L, R));
return ans;
}
int main(){
int n, q, x, l, r;
scanf("%d %d", &n, &q);
memset(c, 0, sizeof(c));
for(int i = 1; i <= n; ++i){
scanf("%d", &x);
add(1, 1, n, i, x);
}
while(q--){
scanf("%d %d", &l, &r);
printf("%d\n", queryMax(1, 1, n, l, r) - queryMin(1, 1, n, l, r));
}
}

/*
题意:
50000个数,2e5次询问,每次询问区间最大值和最小值的差。

思路:
线段树裸题。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息