您的位置:首页 > 其它

Mondriaan's Dream (状态dp)

2017-12-03 23:36 190 查看
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt
of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.



Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output


For each test case, output the number of different ways the given rectangle can be filled with small
rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output
1
0
1
2
3
5
144
51205


题目大概:

给你一个n*m的矩阵,用1*2的方块填满;

思路:

状态压缩dp。

因为状态只有两个 放和不放,用0 1表示。并且矩形最大为11.

这就可以用一个数来表示一行的状态。

比如一个4*4的矩形,可以用15表示 1111,表示这行都被填满。

有三种放的方法,用dfs来实现。

1 竖直放,

2 横着放

3 不放。

这个时看的一个人的dfs+dp的题解,

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
const int le=1<<12;
ll dp[2][le];
int w,h,p,q;
void dfs(int pos,int st,int qian)
{
if(pos==w)
{
dp[q][st]+=dp[p][qian];
return;
}
if(pos+1<=w)
{
dfs(pos+1,st<<1,qian<<1|1);
dfs(pos+1,st<<1|1,qian<<1);
}
if(pos+2<=w)
{
dfs(pos+2,st<<2|3,qian<<2|3);
}
}
int main()
{
while(scanf("%d%d",&w,&h)&&(w||h))
{
if(((w*h)&1)||(w==0&&h==0))
{
printf("0\n");
continue;
}
p=0;
memset(dp,0,sizeof(dp));
dp[0][(1<<w)-1]=1;
for(int i=1;i<=h;i++)
{
q=p^1;
dfs(0,0,0);
memset(dp[p],0,sizeof(dp[0]));
p=q;
}
printf("%I64d\n",dp[p][(1<<w)-1]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息