您的位置:首页 > 运维架构

hdu - 4349 - Xiao Ming's Hope - (Lucs定理)

2017-12-03 22:08 435 查看
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their
girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of
course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers.
When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he
found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

InputEach line contains a integer n(1<=n<=10 8)
OutputA single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).
Sample Input
1
2
11


Sample Output
2
2
8


题意是给出n让求 C (n,0),C (n,1),C (n,2)...C (n,n)中有多少个是奇数

先说下卢卡斯定理:

A、B是非负整数,p是质数。AB写成p进制:A=a
a[n-1]...a[0],B=b
b[n-1]...b[0]。则组合数C(A,B)与C(a
,b
)*C(a[n-1],b[n-1])*...*C(a[0],b[0]) modp同余

即:Lucas(n,m,p)=c(n%p,m%p)*Lucas(n/p,m/p,p) ,表示为组合数:C(n,m)%p=C(n/p,m/p)*C(n%p,m%p)%p

再结合看到别人说的以下官方题解,就很好理解了

本题为Lucas定理推导题,我们分析一下 C(n,m)%2,那么由lucas定理,我们可以写成二进制的形式观察,比如 n=1001101,m是从000000到1001101的枚举,我们知道在该定理中C(0,1)=0,因此如果n=1001101的0对应位置的m二进制位为1那么C(n,m) % 2==0,因此m对应n为0的位置只能填0,而1的位置填0,填1都是1(C(1,0)=C(1,1)=1),不影响结果为奇数,并且保证不会出n的范围,因此所有的情况即是n中1位置对应m位置0,1的枚举,那么结果很明显就是:2^(n中1的个数)

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cst
4000
ring>
#include<map>
using namespace std;

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int sum=0; //记录n转化为2进制后1的个数
while(n)
{
if(n&1)
sum++;
n=n>>1; //其实这里是取n%2即a[i],如果a[i]=1无论b[i]=0或1,C(a[i],b[i])都=1
}
int ans=pow(2,sum);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: