您的位置:首页 > 其它

POJ1611 The Suspects(并查集)

2017-12-02 17:59 330 查看
The Suspects

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

题意:有N个人分成M组,编号从0到N-1。称呼可能患有病的人为嫌疑犯,只要一组里面有一个嫌疑犯,那么全组都是。现在为了预防病的传染,需要判断有多少个嫌疑犯。我们已经知道编号为0的人是嫌疑犯 且 一个人可能分属不同的几个组。

思路:合并每一组里面的人 + 从头查询, 并查集模版题。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define MAXN 30
int pre[30030];
int sum[30010];
int find(int x)
{
int r = x;      //用r来传递信息
while(pre[r] != r)  //如果r的上级bushir自身
r = pre[r];     //r就接着找上级,直到找到老大
return r;           //告诉你x的老大是谁
}

void join(int x, int y)     //x,y成为朋友,于是他们两个的联盟合并了
{
int fx = find(x);       //找x的老大
int fy = find(y);       //找y的老大
if(fx != fy){
pre[fx] = fy;       //x的老大成了y老大的小弟
sum[fy] += sum[fx];
}
}

int main()
{
int n, m, i, j, num[30010];
while(cin >> n >> m&&( n||m))
{
for(j=0; j<n; j++){
pre[j] = j;
sum[j] = 1;
}
while(m--)
{
int a;
cin >> a;
for(i=0; i<a; i++){
cin >> num[i];
}
for(i=0; i<a-1; i++){
join(num[i], num[i+1]);
}
}
int t = find(0);
cout << sum[t] << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: