您的位置:首页 > 移动开发

HOJ 5199 Happy Matt Friends (暴力dp)

2017-12-02 10:00 537 查看


Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 4863    Accepted Submission(s): 1841


Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

 

Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

 

Sample Input

2
3 2
1 2 3
3 3
1 2 3

 

Sample Output

Case #1: 4
Case #2: 2

HintIn the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交) 

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6242 6241 6240 6239 6238 

第一次忘了考虑0的时候。。。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 3000010;
using ll = long long;
ll dp[2][maxn];
int n, m;
int a[50];
int main() {
//freopen("in.txt", "r", stdin);
int t, cur;
cin >> t;
for (int ca = 1; ca <= t; ++ca) {
memset(dp, 0, sizeof(dp));
cin >> n >> m;
for (int i = 0; i < n; ++i) {
cin >> a[i];
}
dp[1][0] = 1;
cur = 1;
for (int i = 0; i < n; ++i) {
cur = 1 - cur;
for (int j = 0; j <= 300000; ++j) {
dp[cur][j] = dp[1 - cur][j] + dp[1 - cur][j ^ a[i]];
}
}
ll res = 0;
for (int i = m; i < maxn; ++i) {
res += dp[cur][i];
}
printf("Case #%d: %lld\n", ca, res);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: