您的位置:首页 > 其它

hdu 2509 Be the Winner

2017-12-02 09:21 337 查看
点击打开链接


Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4117    Accepted Submission(s): 2282


Problem Description

Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

 

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

 

Output

If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

 

Sample Input

2
2 2
1
3

 

Sample Output

No
Yes

 
anti-nim游戏:谁拿走最后一个谁输。

结论:先手胜当且仅当 (1).所有堆石子数都为1且游戏的SG值为0。(2).存在某堆石子数大于1且SG的值不为0

证明:

(1).若所有堆石子数都为1且SG值为0,则共有偶数堆石子,所以先手胜。

(2).a.只有一堆石子数大于1时,我们可以对该堆石子进行操作,使操作后石子堆数为奇数且所有堆得石子数均为1

     b.有超过一堆石子数大于1时,先手将SG值变为0即可,且总存在某堆石子数大于1

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int n;
int s[110];
while(cin>>n)
{
int t,flag=0;
for(int i=0;i<n;i++)
{
cin>>s[i];
if(i==0)
t=s[0];
else
t^=s[i];
if(s[i]>1)
flag=1;
}
if(!flag)
{
if(n&1)
printf("No\n");
else
printf("Yes\n");
continue;
}
if(t==0)
printf("No\n");
else
printf("Yes\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: