您的位置:首页 > 其它

hdu 5534 Partial Tree 背包DP

2017-12-01 12:34 399 查看
参考:http://www.cnblogs.com/qscqesze/p/4967071.htmlhttp://blog.csdn.net/qq_21057881/article/details/52598441

Partial Tree

Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5534

Description

In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has n nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn−2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?

Input

The first line contains an integer T indicating the total number of test cases.

Each test case starts with an integer n in one line,

then one line with n−1 integers f(1),f(2),…,f(n−1).

1≤T≤2015

2≤n≤2015

0≤f(i)≤10000

There are at most 10 test cases with n>100.

Output

For each test case, please output the maximum coolness of the completed tree in one line.

Sample Input

2

3

2 1

4

5 1 4

Sample Output

5

19

HINT

题意

给你n个点,让你构造出一棵树

假设这棵树最后度数为k的点有num[k]个,那么这棵树的价值为sigma(num[i]*f[i])

其中f[i]是已经给定的

思路:一棵树有2(n-1)个度,每个度都有它的权值,那么就相当于一个容量为2*(n-1)的背包,物品的体积是度数,可是这样有可能会出现没有被选的度数,那么我们就先每个点都分配一个度,然后就是完全背包啦

#include<bits/stdc++.h>
using namespace std;
const int maxn = 25000;
int a[maxn];
int dp[maxn];
int main()
{
int T,n;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i = 0;i<n-1;i++)
scanf("%d",&a[i]);
int V = 2*(n-1)-n;
for(int i = 0;i<=n;i++)
dp[i]=-1e9;
dp[0]=a[0]*n;
for(int i=1;i<n-1;i++)
a[i]-=a[0];
for(int i = 1;i<=V;i++)
for(int j = i;j<=V;j++)
dp[j]=max(dp[j],dp[j-i]+a[i]);
printf("%d\n",dp[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: