您的位置:首页 > 其它

PAT - 甲级 - 1070. Mooncake (25)(贪心)

2017-11-29 21:43 369 查看
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of
the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can
be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive
inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5

Sample Output:
9.45


给定条件:

1.n种不同的月饼,市场对月饼的最大需求量

2.给出这n中月饼的数量和价格(总价)

要求:

1.市场如何进货能获取最大营业额

求解:

1.在需求量一定的情况下,肯定是要进货价格最高的

2.将月饼按照单价高低进行排序

3.尽可能多的购进单价高的月饼(直至达到最大需求量或者购完所有月饼)

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct moonCake {
double mounts;
double price;
double ave;
} mk[1010];
bool cmp1(moonCake mk1, moonCake mk2) {
return mk1.ave > mk2.ave;
}

int n, d;
double ans = 0.0;

int main() {
scanf("%d%d", &n, &d);
for(int i = 0; i < n; i++) {
scanf("%lf", &mk[i].mounts);
}
for(int i = 0; i < n; i++) {
scanf("%lf", &mk[i].price);
mk[i].ave = mk[i].price / mk[i].mounts;
}

sort(mk, mk+n, cmp1);

for(int i = 0; i < n && d > 0; i++) {
if(mk[i].mounts > d) {
ans += mk[i].ave * d;
d = 0;
} else {
ans += mk[i].price;
d -= mk[i].mounts;
}
}
printf("%.2f\n", ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: