您的位置:首页 > 其它

HDU2020绝对值排序

2017-11-29 21:07 218 查看
/*

绝对值排序

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 88380 Accepted Submission(s): 41794

Problem Description

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。

Sample Input

3 3 -4 2

4 0 1 2 -3

0

Sample Output

-4 3 2

-3 2 1 0

*/

#include <stdio.h>
#include <math.h>
#include <malloc.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
struct obj{
int key;
int flag;
}a[102],b[102];
bool cmp(const obj &a,const obj &b)
{
return a.key>b.key;
}
int main()
{
int n;
while(cin>>n)
{
if(n==0)
{
break;
}
for(int i=0;i<n;i++)
{
cin>>a[i].key;
if(a[i].key<0)
{
b[i].key=-a[i].key;
b[i].flag=1;
}
else
{
b[i].key=a[i].key;
b[i].flag=0;
}
}
sort(b,b+n,cmp);
for(int i=0;i<n-1;i++)
{
if(b[i].flag==1)
{
cout<<-b[i].key<<" ";
}
else{
cout<<b[i].key<<" ";
4000
}
}
if(b[n-1].flag==1)
{
cout<<-b[n-1].key<<"\n";
}
else{
cout<<b[n-1].key<<"\n";
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: