您的位置:首页 > 其它

1008电梯问题

2017-11-28 22:05 183 查看
`The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2

3 2 3 1

0

Sample Output

17

41

#include<stdio.h>

int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n&&n<100)//要连续不断地输入n,且n的值每次都要小于100
{
int a[100];//不能定义为a
要输入常量表达式
int i;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);//定义一个a的一维数组
if(a[i]>=100)   return 0;

}
int sum;//用来计算需要的时间
sum=a[0]*6+5;
for(i=0;i<n-1;i++)
{
if(a[i+1]>a[i]) sum+=(a[i+1]-a[i])*6+5;//每一层上楼都需要6s和停顿5s
if(a[i+1]<a[i]) sum+=(a[i]-a[i+1])*4+5;//每上一层楼都需要4s和停顿5s
if(a[i+1]==a[i]) sum+=5;//不改变楼层时停顿5s
}
printf("%d\n",sum);

}
return 0;
}


“`
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: