您的位置:首页 > 其它

POJ-2386-Lake Counting

2017-11-27 23:56 363 查看
                                       Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer
John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output

3
题意:给定一个N*M的图,求联通块。

题解:联通块模板题,dfs搜索即可。

AC代码:

/*
* @Author: 王文宇
* @Date: 2017-11-27 15:20:31
* @Last Modified by: 王文宇
* @Last Modified time: 2017-11-27 15:35:20
*/
#include<iostream>
using namespace std;
const int maxn = 105;
char a[maxn][maxn];
int n,m,vis[maxn][maxn],ans;
int ax[4]={-1,1,0,0};
int ay[4]={0,0,-1,1};
void dfs(int x,int y,int z)
{
vis[x][y]=1;
for(int i=0;i<4;i++)
{
for(int j=0;j<4;j++)
{
int x1 = x+ax[i];
int y1 = y+ay[j];
if(x1<1||x1>n||y1<1||y1>m)continue;
if(vis[x1][y1]==0&&a[x1][y1]=='W')dfs(x1,y1,z);
}
}
return ;
}
int main(int argc, char const *argv[])
{
cin>>n>>m;
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
vis[maxn][maxn]=0;
cin>>a[i][j];
}
ans = 0;
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
if(vis[i][j]==0&&a[i][j]=='W')dfs(i,j,ans++);
}
cout<<ans<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: