您的位置:首页 > 其它

a letter and a number

2017-11-27 18:22 274 查看

a letter and a number

时间限制:3000 ms  |  内存限制:65535 KB难度:1描述 we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).输出for each case, you should the result of y+f(x) on a line样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
上传者苗栋栋
#include<stdio.h>
int main()
{
    int k;
    scanf("%d",&k);
    getchar();
    while(k--)
    {
        char zw;
        int j,sum=0;
        scanf("%c %d",&zw,&j);
        if(zw>='A'&&zw<='Z')
           {sum+=(zw-64);}
        else
            {sum+=(96-zw);}            //是96-zw;
        sum=sum+j;
        printf("%d\n",sum);
        getchar();                            //绝不能少,不然下一个zw会是换行字符;
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: