您的位置:首页 > 产品设计 > UI/UE

HDOJ-1711 Number Sequence (kmp模板)

2017-11-27 11:40 337 查看
Number Sequence

Time Limit: 10000/5000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Given two sequences of numbers : a[1], a[2], …… , a
, and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a
. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

题意:

第一行给出样例数

第二行给处pattern串和目标串的长度

第三行输入目标串

第四行输入模板串

输出匹配到的第一个位置

题解:

#include<bits/stdc++.h>
using namespace std;
const int N = 1e7;
int t
, p
, Next
;//t为target串,p为pattern串
int n, m;//n为target串长度,m为pattern串长度
void next() {//next[i]表示i长度的匹配串所拥有的 最长相同前缀后缀 长度
Next[0] = -1;
int i = 0, j = -1;//i为pattern串的指针,j为Next数组的指针
while (i < m) {//没有到pattern的末尾
if (j == -1 || p[i] == p[j]) {//当前位置匹配
i++; //移动到下一个位置
j++;//匹配个数增加
Next[i] = j;//i位置的匹配数为j
}
else j = Next[j];//不匹配就向前回溯
}
}

int KMP() {
int i = 0, j = 0;
next();
while (i < n) {//还没匹配完
if (t[i] == p[j] || j == -1) i++, j++;//匹配成功
else j = Next[j];//回溯
if (j == m) return i - (m - 1);//返回匹配成功的开头位置
}
return -1;
}

int main() {
int cases;
cin >> cases;
while (cases--) {
cin >> n >> m;
for (int i = 0; i < n; i++) scanf("%d", &t[i]);
for (int i = 0; i < m; i++) scanf("%d", &p[i]);
if (m > n) cout << -1 << endl;
else {
cout << KMP() << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp